| 注册
请输入搜索内容

热门搜索

Java Linux MySQL PHP JavaScript Hibernate jQuery Nginx
datagetter
6年前发布

从GitHub上克隆code装mediawiki的一次经历

来自: http://lolicookie.herokuapp.com/cong-githubshang-ke-long-codezhuang-mediawikide-qu-zhe-jing-li/

寻找git源

去年有一段时间我写了一个畅言的mw插件,但是感觉当时那个写得并不是很好所以打算最近重新整理下,不巧的是前几天作死在c9上配置ss结果原来的账号被封了,无奈重新注册了一个,还得重新开workspace装一遍。

于是这次就打算试试新玩法了,我在github上star了mediawiki的git库,我就这次想拿它装一次,去GitHub上翻到了那个repostiory(在 这里 ),随便翻了release,找到了一个1.26的release,但是好像只有压缩包下载,这好像不是我想要的(当然也有commit id,应该可以拿这个clone下来,我没试)。回来又翻了一下branch,看到了我需要的东西

这里的release都有对应的branch,比如 REL1_3 这个就代表着是version=1.3的release

clone代码,目录非空?

我挑了一个1.26的(因为我参与维护的一个wiki站就用的1.26),复制了git地址,然后回来在c9的bash下敲

git clone git@github.com:wikimedia/mediawiki.git -b REL1_26 .  

后面的那个 . 代表我要把代码clone到当前文件夹而不是建个文件夹放里。但是却始终给我报错

fatal: destination path '.' already exists and is not an empty directory.  

当前目录非空。确实非空,因为c9的workspace目录里有几个用来演示的文件,还有一个 php.ini 用来让用户配置自己的php环境,其他的那两个可以删但php.ini不太想删,删完怕以后麻烦,goolge了一下stackoverflow上也有人遇到了这样的情况,后来下面有一个解决方案,看完之后我有种想撞墙的冲动233333

git init .    git remote add -t \* -f origin <repository-url>    git checkout master  

原文在 这里

need composer

完整的pull下来之后乍一看占用大小足足占了500m,蛮大的,后来维护群里的一位大牛说可以用 --depth=1 来指定深度嘛,好吧我竟然忘了

本以为像往常一样,直接打开apache和mysql就可以跑了,没想到打开却提示我错误

细一看是需要composer,后面引导了一个官网的页面( 这里 ),里面有一段话说明了如何安装

Fetch external libraries

Starting with MediaWiki 1.25, some external libraries that MediaWiki requires are no longer in this "core" git repository. We use composer to manage them. To install these needed libraries, you have a choice:

* Download and install composer , switch to your core directory and then run composer install --no-dev. Note that if you have an existing composer.lock file you will need to run composer update --no-dev instead.

* If you don't want to use composer, or if you want to use the same set of vendor libraries as used on the WMF production cluster, you can instead git clone https://gerrit.wikimedia.org/r/p/mediawiki/vendor.git to create a vendor/ directory inside the core folder of your MediaWiki installation. Make sure you use the right branch for your MediaWiki version (e.g. REL1_25 for 1.25).

</div>

按图索骥,先下载composer

curl -sS https://getcomposer.org/installer | php  

然后按照mw官方说明compose

composer install --no-dev  

运行后会提示当前的compose进度,等走完就可以了

core版并没有主题

从安装第一步开始就感觉界面怪怪的,直到后面提示我没有主题 装完后打开主页提示了我重点 查资料才知道 mw从1.24起core就不带主题了 ,于是到这个 用git的皮肤存储库 里clone了了默认皮肤 Vector 到 skins/ 目录,在 LocalSetting.php 中把皮肤require进来

require_once "$IP/skins/Vector/Vector.php";  

然后再进,一切就搞定了√

</div>

 本文由用户 datagetter 自行上传分享,仅供网友学习交流。所有权归原作者,若您的权利被侵害,请联系管理员。
 转载本站原创文章,请注明出处,并保留原始链接、图片水印。
 本站是一个以用户分享为主的开源技术平台,欢迎各类分享!