MyEclipse使用技巧

amx5l

贡献于2011-09-19

字数:9200 关键词: Eclipse开发工具

MyEclipse的配置 1、 代码提示功能 这是我们使用MyEclipse时最常用的工具,通常我们会将提示的快捷键设置为Alt+/。下面具体介绍一下设置的方式。 Windows—>PerferencesàGeneralàKeysàContent Assist 将其绑定为Alt+/,这里要注意一下,在设置的时候,一定要保证Alt+/没有被其他的命令所绑定。默认情况下,该快捷方式已经被绑定,需要先将绑定移出。移出的方式是,选中要移出的绑定,然后点击Remove Binding按钮,然后点击Apply,最后点击OK即解除了绑定。 2、添加自动联想功能 默认情况下,只有在我们输入“.”号时,才会有联想功能,我们希望在我们输入任意一个字符的时候,都能够出现联想的功能。那么就需要自己进行相关配置,具体的配置方式如下: (1)WindowsàPerferencesàJavaàEditoràContent AssistàAuto activation triggers for Java 在右边的框框中将“.”号改为“.abc”; (2)File—>ExportàPerferences 点击Next,在对话框中,点击Browse按钮选择到处文件存放的路径。点击Finish即完成到出。假设到处的文件的名字是zk.epf (3)用记事本将zk.epf文件打开,ctrl+F搜索“.abc”找到对应的地方,用“.abcdefghijklmnopqrstuvwxyz(,”替换“.abc”,保存文件。 (4)File—>importàPerferences 点击Next,在对话框中,点击Browse按钮选择要导入的文件,点击Finish,即完成了联想配置。 3、解决MyEclipse在代码提示时经常卡死的问题 出现代码提示时卡死的情况主要是因为MyEclipse在智能提示的时候自动访问网络上sun公司的最新API文档,解决该问题有两种方式: (1)断开网络。这种方式比较死板,而且很多时候不是很方便,所以不推荐大家用这中方式。 (2)在自己要编辑的工程上右键,Build PathàConfigure Build PathàLibrariesàJRE System Libraryàrt.jar;将rt.jar展开,选中Javadoc,点击右边面板上的Remove按钮—>OK按钮,这样配置之后,智能提示时就不会再卡死了 eclipse 自动补全的设置,不用按 alt-/ 了 打开 Eclipse -> Window -> Perferences,会打开个Perferences 的设置界面。 会看到只有一个"."存在。表示:只有输入"."之后才会有代码提示,我们要修改的地方就是这里,可是Eclipse默认只允许输入4个自定义字符。 不过我们可以把当前的设置导出,保存为一个文件,然后在文件中修改,再导入设置,这样就可以突破Eclipse的限制。 先把上图中"."的地方输入几个随便的字符,例如"asdf",点最下面的"OK"来保存设置。 然 后打开 Eclipse的 File -> Export,在窗口中展开 General -> Perferences-->Export all然后点击 NEXT。然后点击"Browse"选择任意的一个路径,保存配置文件,然后点击"Finish"。 用记事本打开刚才保存的那个配置文件(扩展文件名:*.epf),按"ctrl + F",输入刚才设置的"asdf",找到刚才字符串。把"asdf"修改为"abcdefghijklmnopqrstuvwxyz.",然后保存,退出记事本。 打 开Eclipse的 File -> Import 然后在打开的窗口里展开 General -> Perferences,点击NEXT,选中刚才修改过的配置文件,Finish。现在,再打开Window -> Perferences,并依次展开 Java -> Editor -> Content Assist,会发现已经超过了4个字符,也就是说我们输入任何字母和"."都会有代码提示了。 修改之后,默认是你输入某个字符200毫秒之后出现代码提示,如果出现输入很卡的情况,需要把提示延迟调高一些;如果你嫌它太慢,可以修改成更小的数字,不过数字改的越小,对系统性能的要求就越高,我设置的是50毫秒。现在,Eclipse用起来是不是更加顺手了? \\ Eclipse快捷键设置 eclipse 自动补全的设置,不用按 alt-/ 了 Eclipse无提示的解决办法! 围绕Ext JS 2.0的IDE、插件和工具 by Jack Slocum 更多相关推荐 一般默认情况下,Eclipse ,MyEclipse 的代码提示功能是比Microsoft Visual Studio的差很多的,主要是Eclipse ,MyEclipse本身有很多选项是默认关闭的,要开发者自己去手动配置。如果开发者不清楚的话,就不知道Eclipse ,MyEclipse的代码提示功能一样能像Microsoft Visual Studio的代码提 示功能一样强大。 先举个简单的例子说明问题所在,例如在Eclipse ,MyEclipse代码里面,打个foreach,switch等 这些,是无法得到代码提示的(不信自己试试),其他的就更不用说了,而在Microsoft Visual Studio 里面是得到非常友好的代码提示的。实际上,Eclipse ,MyEclipse代码里面的代码提示功能默认的一般 是点“.”,一般是有了点“.”,才会有代码提示。 原理:“Auto Activation triggers for java”这个选项就是指触发代码提示的的选项,把“.” 改成“.abcdefghijklmnopqrstuvwxyz(,”的意思,就是指遇到26个字母和.,(这些符号就触发代码提 示功能了。(具体后面有说,放心)增强Eclipse ,MyEclipse 的代码提示功能,具体怎么样来配置?下面开始说步骤(注意本人用的 MyEclipse 6.0.1做讲解): 1. 打开MyEclipse 6.0.1,然后“window”→“Preferences” 2. 选择“java”,展开,“Editor”,选择“Content Assist”。 3. 选择“Content Assist”,然后看到右边,右边的“Auto-Activation”下面的“Auto Activation triggers for java”这个选项。其实就是指触发代码提示的就是“.”这个符号. 4. “Auto Activation triggers for java”这个选项,在“.”后加abc字母,方便后面的查找 修改。然后“apply”,点击“OK”。 5. 然后,“File”→“Export”,在弹出的窗口中选择“Perferences”,点击“下一步”。 6. 选择导出文件路径,本人导出到桌面,输入“test”作为文件名,点击“保存”。 7. 在桌面找到刚在保存的文件“test.epf”,右键选择“用记事本打开”。 8. 可以看到很多配置MyEclipse 6.0.1的信息 9. 按“ctrl + F”快捷键,输入“.abc”,点击“查找下一个”。 10. 查找到“.abc”的配置信息. 11. 把“.abc”改成“.abcdefghijklmnopqrstuvwxyz(,”,保存,关闭“test.epf”。 12. 回到MyEclipse 6.0.1界面,“File”→“Import”,在弹出的窗口中选择“Perferences”,点击 “下一步”,选择刚在已经修改的“test.epf”文件,点击“打开”,点击“Finish”。该步骤和上面 的导出步骤类似。 13. 最后当然是进行代码测试了。随便新建一个工程,新建一个类。在代码输入switch,foreach等进行 测试。你立即会发现,果然出了提示,而且无论是敲哪个字母都会有很多相关的提示了,很流畅,很方便。 总结:“Auto Activation triggers for java”这个选项就是指触发代码提示的的选项,把“.”改成 “.abcdefghijklmnopqrstuvwxyz(,”的意思,就是指遇到26个字母和.,(这些符号就触发代码提示功 能了。 顺便说一下,修改类名,接口名等以不同颜色高亮的,可以这样配置在“java”→“enditor”→ “syntac”,右边展开“java”→“classes”,勾上“Enable”这个选项,选择自己喜欢的颜色即可。 当然还有其他相关的颜色配置。具体就不说啦。其实,在“Preferences”这个东西,有很多可以配置的 东西,使得MyEclipse 优化的,具体的就要各个人根据自己个人喜好去配置了。 主题:MyEclipse快捷键与插件大全精华帖帖 推荐圈子: IntelliJ IDEA 更多相关推荐 Eclipse 快捷键(1) Ctrl+1 快速修复(最经典的快捷键,就不用多说了) Ctrl+D: 删除当前行 Ctrl+Alt+↓ 复制当前行到下一行(复制增加) Ctrl+Alt+↑ 复制当前行到上一行(复制增加) Alt+↓ 当前行和下面一行交互位置(特别实用,可以省去先剪切,再粘贴了) Alt+↑ 当前行和上面一行交互位置(同上) Alt+← 前一个编辑的页面 Alt+→ 下一个编辑的页面(当然是针对上面那条来说了) Alt+Enter 显示当前选择资源(工程,or 文件 or文件)的属性 Shift+Enter 在当前行的下一行插入空行(这时鼠标可以在当前行的任一位置,不一定是最后) Shift+Ctrl+Enter 在当前行插入空行(原理同上条) Ctrl+Q 定位到最后编辑的地方 Ctrl+L 定位在某行 (对于程序超过100的人就有福音了) Ctrl+M 最大化当前的Edit或View (再按则反之) Ctrl+/ 注释当前行,再按则取消注释 Ctrl+O 快速显示 OutLine Ctrl+T 快速显示当前类的继承结构 Ctrl+W 关闭当前Editer Ctrl+K 参照选中的Word快速定位到下一个 Ctrl+E 快速显示当前Editer的下拉列表(如果当前页面没有显示的用黑体表示) Ctrl+/(小键盘) 折叠当前类中的所有代码 Ctrl+×(小键盘) 展开当前类中的所有代码 Ctrl+Space 代码助手完成一些代码的插入(但一般和输入法有冲突,可以修改输入法的热键,也可以暂用Alt+/来代替) Ctrl+Shift+E 显示管理当前打开的所有的View的管理器(可以选择关闭,激活等操作) Ctrl+J 正向增量查找(按下Ctrl+J后,你所输入的每个字母编辑器都提供快速匹配定位到某个单词,如果没有,则在stutes line中显示没有找到了,查一个单词时,特别实用,这个功能Idea两年前就有了) Ctrl+Shift+J 反向增量查找(和上条相同,只不过是从后往前查) Ctrl+Shift+F4 关闭所有打开的Editer Ctrl+Shift+X 把当前选中的文本全部变味小写 Ctrl+Shift+Y 把当前选中的文本全部变为小写 Ctrl+Shift+F 格式化当前代码 Ctrl+Shift+P 定位到对于的匹配符(譬如{}) (从前面定位后面时,光标要在匹配符里面,后面到前面,则反之) 下面的快捷键是重构里面常用的,本人就自己喜欢且常用的整理一下(注:一般重构的快捷键都是Alt+Shift开头的了) Alt+Shift+R 重命名 (是我自己最爱用的一个了,尤其是变量和类的Rename,比手工方法能节省很多劳动力) Alt+Shift+M 抽取方法 (这是重构里面最常用的方法之一了,尤其是对一大堆泥团代码有用) Alt+Shift+C 修改函数结构(比较实用,有N个函数调用了这个方法,修改一次搞定) Alt+Shift+L 抽取本地变量( 可以直接把一些魔法数字和字符串抽取成一个变量,尤其是多处调用的时候) Alt+Shift+F 把Class中的local变量变为field变量 (比较实用的功能) Alt+Shift+I 合并变量(可能这样说有点不妥Inline) Alt+Shift+V 移动函数和变量(不怎么常用) Alt+Shift+Z 重构的后悔药(Undo) Ctrl + Z 返回到修改前的状态(编写代码时的后悔药) Ctrl + Y 与上面的操作相反 (即刚后悔完又后悔) Shift + / 自动导入类包 (在你写好的类名的右边用这个可导入包) Ctrl + Shif + / 自动注释代码 Ctrl + Shif + \自动取消已经注释的代码 Ctrl + Shif +O 自动引导类包 MyEclipse 快捷键(2)[b][/b][color=#FF0000][/color] (1)Ctrl+M切换窗口的大小 (2)Ctrl+Q跳到最后一次的编辑处 (3)F2当鼠标放在一个标记处出现Tooltip时候按F2则把鼠标移开时Tooltip还会显示即Show Tooltip Description。 F3跳到声明或定义的地方。 F5单步调试进入函数内部。 F6单步调试不进入函数内部,如果装了金山词霸2006则要把“取词开关”的快捷键改成其他的。 F7由函数内部返回到调用处。 F8一直执行到下一个断点。 (4)Ctrl+Pg~对于XML文件是切换代码和图示窗口 (5)Ctrl+Alt+I看Java文件中变量的相关信息 (6)Ctrl+PgUp对于代码窗口是打开“Show List”下拉框,在此下拉框里显示有最近曾打开的文件 (7)Ctrl+/ 在代码窗口中是这种//~注释。 Ctrl+Shift+/ 在代码窗口中是这种/*~*/注释,在JSP文件窗口中是。 (8)Alt+Shift+O(或点击工具栏中的Toggle Mark Occurrences按钮) 当点击某个标记时可使本页面中其他地方的此标记黄色凸显,并且窗口的右边框会出现白色的方块,点击此方块会跳到此标记处。 (9)右击窗口的左边框即加断点的地方选Show Line Numbers可以加行号。 (10)Ctrl+I格式化激活的元素Format Active Elements。 Ctrl+Shift+F格式化文件Format Document。 (11)Ctrl+S保存当前文件。 Ctrl+Shift+S保存所有未保存的文件。 (12)Ctrl+Shift+M(先把光标放在需导入包的类名上) 作用是加Import语句。 Ctrl+Shift+O作用是缺少的Import语句被加入,多余的Import语句被删除。 (13)Ctrl+Space提示键入内容即Content Assist,此时要将输入法中Chinese(Simplified)IME-Ime/Nonlme Toggle的快捷键(用于切换英文和其他文字)改成其他的。 Ctrl+Shift+Space提示信息即Context Information。 (14)双击窗口的左边框可以加断点。 (15)Ctrl+D删除当前行。 主题:优化MyEclipse7.5(其他版本可以类推) 让Eclipse拖着myeclipse狂飚 JAVA环境变量配置与TOMCAT配置以及MyEclipse开发环境的优化 给MyEclipse 8.x Stable (8.0 GA) 添加启动画面 更多相关推荐 1、去除不需要加载的模块 一个系统20%的功能往往能够满足80%的需求,MyEclipse也不例外,我们在大多数时候只需要20%的系统功能,所以可以将一些不使用的模块禁止 加载启动。通过Windows - Preferences打开配置窗口,依次选择左侧的General - Startup and Shutdown,这个时候在右侧就显示出了Eclipse启动时加载的模块,可以根据自己的实际情况去除一些模块。 windows–>perferences–>general–>startup and shutdown 关掉没用的启动项: WTP :一个跟myeclipse差不多的东西,主要差别是 WTP 是免费的,如果使用myeclipse,这个可以取消 Mylyn:组队任务管理工具,类似于 CVS ,以任务为单位管理项目进度,没用到的可以取消 Derby:一种保存成 jar 形式的数据库,我没用到,取消 一大排以 MyEclipse EASIE 打头的启动项:myeclipse 支持的服务器,只选自己用的,其他取消,比如我只选了tomcat6.x 2、取消MyEclipse在启动时自动验证项目配置文件 默认情况下MyEclipse在启动的时候会自动验证每个项目的配置文件,这是一个非常耗时的过程, 可以在Preferences窗口依次选择 MyEclipse Enterprise Workbench - Validation,然后在右侧的Validator列表中只保留 Manual 项就可以了(Manual全部勾选,Bulid项只留下第一项)。 如果需要验证的时候只需要选中文件,然后右键选择 MyEclipse - Run Validation就可以了。 windows–>perferences–>myeclipse–>validation 把 除了manual 下面的全部点掉,build下只留 classpath dependency Validator 手工验证方法: 在要验证的文件上,单击鼠标右键–>myeclipse–>run validation 3、去掉拼写检查(如果你觉的有用可以不去) 拼写检查会给我们带来不少的麻烦,我们的方法命名都会是单词的缩写,他也会提示有错,所以最好去掉,没有多大的用处: windows–>perferences–>general–>validation->editors->Text Editors->spelling myeclipse 打开 jsp 的默认编辑器不好,会同时打开预览 windows–>perferences–>general–>editors->file associations, 把默认改成 MyEclipse JSP Editor() 原默认的jsp编辑器是 MyEclipse Visual JSP Designer,顾名思义,此编译器是jsp可视化编辑器,对于初学者有很多的帮助, 但修改此项的默认编辑器其实可以提高启动速度) 4、关闭自动更新 如果是myeclipse7.5: (1)关掉maven自动更新: window-preferences-MyEclipse Enterprise Workbench-Maven4MyEclipse-Maven, 关闭所有Download和Update开头的选项,共四项(去掉前面的勾) (2)关闭更新调度:window –> preferences –> General –> Startup and Shutdown –> Automatic Updates Scheduler(去掉前面的勾) (3)window –> preferences –>Myeclipse Dashboard,关闭Show……on start 5、加大JVM的非堆内存 打开 myeclipse.ini -startup ../Common\plugins\org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.jar --launcher.library ../Common\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.101.R34x_v20080731 -clean -configuration configuration -vm C:\Users\lenovo\AppData\Local\Genuitec\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll -vmargs -Xmx384m -XX:MaxPermSize=384m -XX:ReservedCodeCacheSize=96m 以上是我的myeclipse.ini,需要修改是-Xmx,-XX:MaxPermSize,-XX:ReservedCodeCacheSize, 将这三项的值调大,但并不是越大越好,曾经在相同的条件下做过测试(内存2GB),-Xmx,-XX:MaxPermSize的值为384m时比512m时要快(视具体的计算机而定), -Xmx,-XX:MaxPermSize的值设为同样大小且两者之和不能超出你的计算机本身的内存大小 6、window-preferences-MyEclipse Enterprise Workbench-Maven4MyEclipse-Maven,将Maven JDK改为电脑上安装的JDK,即不使用myeclipse提高的JDK 登记add按钮,选择你的电脑上的JDK即可(注意:不是JRE,我的值为:Java6.014) 7、window-preferences-MyEclipse Enterprise Workbench-Matisse4Myeclipse/Swing,将Design-time information(dt.jar) location 改用电脑安装的JDK的dt.jar (即不使用myeclipse提供的dt.jar,我的值为:C:\Java6.014\lib\dt.jar) 附:MyEclipse的基础配置: 1. 先安装MyEclipse,安装MyEclipse7.5需要VPN代理,安装过程大概持续10-15分钟,使用VPN测试帐号即可 2. 进行MyEclipse的配置, 从菜单栏中进入“Windows --> Preferences” 3. 先要进行JDK的配置, 在左侧栏中选择“Java --> Installed JREs”, 按“Add”按钮进行添加 4. 在弹出的“Add JRE”画面中,选择JRE的目录, 就是选择你所在的JDK的目录,我的为:C:\Program Files\Java\jre6 在JRE名称一栏中,填下想取的名称,我这里叫“HiJackson's JRE”, 然后“OK”确定 5. 返回到设置框中,将刚刚配置的JRE选中 6. 将Tomcat Server设为可用,并设置Tomcat的安装目录 7. 在Tomcat的JDK中选择刚刚配置的JDK 8. 配置完成了,三个地方可以启动它的服务,根据自己的喜好吧 经过以上的优化,myeclipse的启动时间可以减少2/3,Tomcat的启动速度可以减少1/2(视具体情况而定), 特别6,7两项的优化效果最明显, 如果只进行前5项,优化的效果有限,短期内确实可以提高启动速度,但是大概半个月后又会变的很慢(具体原因不明) 另外,使用myeclipse一段时间后,就会产生很多项目,即使这些项目是处于关闭状态,myecliose在启动时也会加载这些项目,这个过程会花费很多时间,所以,建议将不用的项目都delete掉,用的时候再import

下载文档,方便阅读与编辑

文档的实际排版效果,会与网站的显示效果略有不同!!

需要 5 金币 [ 分享文档获得金币 ]
1 人已下载

下载文档

相关文档